范文大全 个人简历 教案下载 课件中心 优秀作文 试题库 考试辅导 诗词鉴赏 散文 实用工具 美食菜谱 中国高校大全
悠久范文网

VLAN

br virtual lans(vlans)vlan basics 如何在1个交换性的网络里,分割广播域呢?答案是创建vlan.vlan是连接到定义好了的switch的端口的网络用户和资源的逻辑分组.给不同的子网分配不同的端口,就可以创建更小的广播域.默认情况下,在某个vlan中的主机是不可以与其他vlan通信的,除非你使用router来创建vlan间的通信 vlan的一些特点: 1.网络的增加,移动和改变,只需要在适当的vlan中配置合适的端口 2.安全,因为不同vlan的用户不能互相通信,除非依靠router来做vlan间的通信 3.因为vlan可以被认为是按功能划分的逻辑分组,所以vlan和物理位置,地理位置无关 4.vlan增加安全性 5.vlan增加广播域的数量,而减小广播域的大小 broadcast control 每种协议都会有广播的现象发生,至于发生不频率,次数,一般由以下几点决定: 1.协议类型 2.在网络上运行的应用程序 3.这些服务如何的被使用 security 安全性是vlan的1大特点,不同vlan的用户不能互相通信,除非依靠router来做vlan间的通信 flexibility and scalability vlan的灵活性和可扩展性: 1.可以不管物理位置如何,把适当的端口分配到适当的 vlan中就可以了.可以把vlan理解正下面的样子:
br
2.当vlan增加的太大以后,你可以划分更多的vlan,来减少广播消耗掉更多带宽的影响,在vlan中的用户越少,被广播影响的就越少,来比较下下面2个图,明显可以发现,图2,即vlan的具有更高的灵活性和可扩展性,如下:

br vlan memberships 手动由管理员分配端口划分的vlan叫静态vlan(static vlan);使用智能管理软件,动态划分vlan的叫动态vlan(dynamic vlan)static vlans静态vlan:静态vlan安全性较高,手动划分端口给vlan,和设备的物理位置没什么关系.而且,每个vlan中的主机必须拥有正确的ip地址信息,如vlan2配置为172.16.20.0/24dynamic vlans动态vlan:使用智能管理软件,可以基于mac地址,协议,甚至应用程序来动态创建vlan.cisco设备管理员可以使用vlan管理策略服务器(vlan management policy server,vmps)的服务来建立个mac地址数据库,来根据这个动态创建vlan,vmps数据库把mac地址映射vlan上identifying vlans当帧在网络中被交换,switches根据类型对其跟踪,加上根据硬件地址来判断如何对它们进行操作.有1点要记住的是:在不同类型的连接中,帧被处理的方式也不一样。交换环境中的2种连接类型:1.access links:指的是只属于一个vlan,且仅向该vlan转发数据帧的端口,也叫做native vlan.switches把帧发送到access-link设备之前,移去任何的vlan信息.而且access-link设备不能与vlan外通信,除非数据包被路由。
  2.trunk links:指的是能够转发多个不同vlan的通信的端口.trunk link必须使用100mbps以上的端口来进行点对点连接,1次最多可以携带1005个vlan信息.trunk link使你的单独的1个端口同时成为数个vlan的端口,这样可以不需要层3设备.当你在switches之间使用了trunk link,多个vlan的信息将从这个连接上通过;如果在你switches之间没有使用trunk link而使用一般的连接,那么只有vlan1的信息通过这个连接被互相传递.vlan1默认作为管理vlanframe taggingframe tagging:帧的鉴别方法.当帧到达每个switch,首先先检查vlan id,然后决定如何对帧进行处理.当帧到达和vlan id所匹配的access link的时候,switch移去vlan标识符vlan identification methodvlan标识符:在交换机的trunk link上,可以通过对数据帧附加vlan信息,构建跨越多台交换机的vlan.附加vlan信息的方法,最具有代表性的有:
  1.inter-switch link(isl):属于cisco私有,只能在快速和千兆以太网连接中使用,isl路由可以使用在switch的断端口,router的接口和服务器接口卡等
  2.ieee 802.1q:俗称dot 1 q.由ieee创建,所以在cisco和非cisco设备之间,就不能使用isl必须使用802.1q.802.1q所附加的vlan识别信息,位于数据帧中的源mac地址与类型字段之间.基于ieee802.1q附加的vlan信息,就像在传递物品时附加的标签。 当然isl和802.1q的主要目的是提供vlan间通信。inter-switch link(isl) protocolisl:isl运作在层2,isl是1种外部标签处理过程,所以原始的数据帧不被改变,isl在数据帧头部加上26字节长的isl头部信息,在数据帧尾部加上4字节的fcs字段进行crc运算,所以只有支持isl的设备才能对它进行读取,最大程度1522字节.当帧被传送到access link时,isl封装信息将被移去使用trunk link在多个vlan中行走,比使用router连接的好处是:减少延时间vlan trunking protocol(vtp)vtp也是cisco创建的,但是现在已经不为cisco所私有.vtp的主要目的是在1个交换性的环境中管理所有配置好的vlan使所有的vlan保持一致性vtp允许增加,删除和重命名vlan,然后这些修改后的信息传播到整个vtp域里的所有switches上vtp的一些优点:
  1.保持vlan信息的连续性
  2.精确跟踪和监视vlan
  3.动态报告增加了的vlan信息给vtp域中所有switch
  4.可以使用即插即用(plug-and-play)的方法增加vlan
  5.可以在混合型网络中进行trunk link,比如以太网到atm lane,fddi等在你使用vtp管理vlan之前,必须先创建个vtp服务器(vtp server),所有要共享vlan信息的服务器必须使用相同的域名.而且,假如你把某个switch和其他的switch配置在1个vtp域里,这个switch就只能和这个vtp域里的switch共享vlan信息.其实,如果你只有1个vlan,就不需要使用vtp了.vtp信息通过trunk端口进行发送和接收.可以给vtp配置密码,但是要记住的是,所有的switch必须配置相同的密码。switch通告vtp管理域信息,加上版本号和已知vlan配置参数信息.还有种叫做透明vtp模式(transparent vtp mode),在这种模式里,你可以给switch配置成通过trunk端口转发vtp信息,但是不接受vtp更新信息来更新它自己的vtp数据库switch通过vtp通告检测到增加的vlan,然后把新增加的vlan和已有的联结在一起共享信息.新的更新信息在之前的版本号上加1。vtp modes of operation在vtp域里操作的3种模式:1.服务器模式(server mode):所有catalyst switches的默认设置,1个vtp域里必须至少要有1个服务器用来传播vlan信息,对vtp信息的改变必须在服务器模式下操作.配置保存在nvram里
  2.客户机模式(client mode):在这种模式下,switches从vtp服务器接受信息,而且它们也发送和接收更新,但是它们不能做任何改变.在vtp服务器通知客户switches说增加了新的vlan之前,你不能在客户switch的端口上增加新的vlan.配置不保存在nvram里
  3.透明模式(transparent mode):该模式下的switch不能增加和删除vlan,因为它们保持的有自己的数据库,不和其他的共享.配置保存在nvram里vtp pruningvtp pruning:减少广播,组播,单播,保留带宽.vtp pruning只在trunk link上发送广播.默认情况,vtp pruning在所有的switches上是没有启用的.当你在vtp服务器上启用了vtp pruning,整个vtp域就启用了vtp pruning,默认只能在vlan2到vlan1005,vlan1是管理vlanrouting between vlans可以使用支持isl路由的router来连接vlan,支持isl路由的最低型号是2600系列,1600,1700和2500系列都不支持.如下图,就是router和每个vlan之间的关联,每个router的接口都插入1个access link,这个同时也说明了router的每个接口的ip地址都是每个vlan的默认网关:
br configuring vlans创建vlan:
  1900下,使用vlan [vlan#] name [name] [vlan#]命令, 如下:
  >en
  #config t
  (config)#hostname 1900
  1900(config)#vlan 2 name sales
  1900(config)#vlan 3 name marketing
  1900(config)#vlan 4 name mis
  1900(config)#exit
验证,使用show vlan命令,记住在你没给vlan分配端口之前,之前做的vlan是不会起作用的.而且所有的端口默认是处在vlan1的,vlan1是管理vlan.如下:1900#sh vlan
  vlan name status ports
  --------------------------------------------------------
  1 default enable 1-12, aui, a, b
  2 sales enable
  3 marketing enable
  (略)在2950下创建vlan,在特权模式下使用vlan database命令,创建命令和1900下的类似,注意结尾使用apply命令.如下:
  2950#vlan database
  2950(vlan)#vlan 2 name marketing
  vlan 2 modified:
  name: marketing
  2950(vlan)#vlan 3 name accounting
  vlan 3 added:
  name: accounting
  2950(vlan)#apply
  apply complete
  2950(vlan)#ctrl+c
  2950#使用show vlan或者show vlan brief命令验证下:
  2950#sh vlan briefvlan name status ports
  -------------------------------------------------------
  1 default active fa0/1...fa0/12
  2 marketing active
  3 accounting active
  (略)assigning switch ports to vlans创建了vlan,接下来要做的就是给vlan分配端口.1900下,使用vlan-membership命令1次只能分配1个,可以  static或dynamic作为参数,如下:
  1900(config)#int e0/2
  1900(config-if)#vlan-membership static 2
  1900(config)#int e0/4
  1900(config-if)#vlan-membership static 3
  1900(config)#int e0/5
  1900(config-if)#vlan-membership static 4
  1900(config-if)#exit
  1900(config)#exit
  1900#
  验证,如下:
  1900#sh vlan
  vlan name status ports
  ------------------------------------------------------
  1 default enable 1-12, aui, a, b
  2 sales enable 2
  3 marketing enable 4
  (略)
  2950下的配置,使用switchport access vlan [vlan#]命令,如下:
  2950(config-if)#int f0/2
  2950(config-if)#switchport access vlan 2
  2950(config-if)#int f0/3
  2950(config-if)#switchport access vlan 3
  2950(config-if)#int f0/4
  2950(config-if)#switchport access vlan 4
  2950(config-if)#exit
  2950(config)#exit
  2950#验证配置信息,如下:
  2950#sh vlan brief
  vlan name status ports
  -------------------------------------------------------
  1 default active fa0/1 fa0/5...fa0/12
  2 marketing active fa0/2
  3 accounting active fa0/3
  (略)configuring trunk ports1900只使用动态isl(disl)封装方式,在快速以太网配置trunk,在接口配置模式下使用trunk [参数]的命令,如下,将26接口设置为trunk端口:
  1900(config)#int f0/26
  1900(config-if)#trunk ?
  auto      set disl state to auto
  desirable   set disl state to desirable
  nonegotiate  set disl state to nonegotiate
  off      set disl state to off
  on      set disl state to on
  1900(config-if)#trunk on
  设置参数为on,即接口将作为永久isl的trunk端口,可以和和相连的设备协商,并且把连接转换成trunk link2950下在接口配置模式,使用switchport命令,如下:
  2950(config)#int f0/12
  2950(config-if)#switchport mode trunk
  2950(config-if)#^z
  2950#
  验证配置信息:
  2950#sh run
  (略)
  !
  interface fastethernet0/12
  switchport mode trunk
  no ip address
  !
  (略)
configuring inter-vlan routing使vlan间互相通信,就必须使用router或者3层switch来连接.要在router的快速以太网接口支持isl和802.1q,要把接口划分成许多逻辑接口(非物理),1个接口对应1个vlan.这些接口就叫子接口(subinterfaces).还有要必须知道的是,默认你不可能在1900和2950之间做trunk连接,因为1900只支持isl路由而2950只支持802.1q路由,2种相互不兼容。给连接1900的trunk端口配置,使用encapsulation isl [vlan#]命令,如下:
  2600router(config)#int f0/0.1
  2600router(config-subif)#encapsulation isl [vlan#]给连接2950的这样配置,如下:
  2600router(config)#int f0/0.1
  2600router(config-subif)#encapsulation dot1q [vlan#]configuring vtp默认下,1900和2950都被配置成vtp服务器模式,配置vtp,先配置vtp域名,还有密码,是否pruning等。1900下,在全局配置模式下使用vtp命令,如下:
  1900(config)#vtp ?
  client vtp client
  domain set vtp domain name
  password set vtp password
  pruning vtp pruning
  server vtp server
  transparent vtp transparent
  trap vtp trap
  1900(config)#vtp server
  1900(config)#vtp domain noco
  1900(config)#vtp password noko在特权模式下使用show vtp命令验证,如下:
  1900#sh vtp
  vtp version: 1
  configuration revision: 0
  maximum vlans supported locally: 1005
  number of existing vlans: 5
  vtp domain name: noco
  vtp password: noko
  vtp operating mode: server
  (略)2950如下:
  2950(config)#vtp mode server
  2950(config)#vtp domain noco
  验证信息,如下:
  2950#sh vtp ?
  counters vtp statistics
  status vtp domain status
  2950#sh vtp status
  (略)
configuring switching in our sample internetwork
假如你有太多的vlan,数量超过了router接口数量,明显上面的方法就不适用了.你可以使用cisco的3层switch cisco3550,或者使用router的快速以太网接口来做isl或者802.1q的 trunk link,这样的方法叫做单臂路由(router on a stick).如下图:
br
先配置2950c,如下
  2950c(config)#enable secret noko
  2950c(config)#line con 0
  2950c(config-line)#login
  2950c(config-line)#password noco
  2950c(config-line)#line vty 0 15
  2950c(config-line)#login
  2950c(config-line)#password noco
  2950c(config-line)#banner motd #
  2950c
  #
  2950c(config-line)#exit
  2950c(config)#int vlan1
  2950c(config-if)#ip address 172.16.10.2 255.255.255.0
  2950c(config-if)#no shut
  2950c(config-if)#exit
  2950c(config)#up default-gateway 172.16.10.1
  2950c(config)#^z
  2950c#copy run start
  配置2950b,如下:
  2950b(config)#enable secret noko
  2950b(config)#line con 0
  2950b(config-line)#login
  2950b(config-line)#password noco
  2950b(config-line)#line vty 0 15
  2950b(config-line)#login
  2950b(config-line)#password noco
  2950b(config-line)#banner motd #
  2950b
  #
  2950b(config-line)#exit
  2950b(config)#int vlan1
  2950b(config-if)#ip address 172.16.10.3 255.255.255.0
  2950b(config-if)#no shut
  2950b(config-if)#exit
  2950b(config)#up default-gateway 172.16.10.1
  2950b(config)#^z
  2950b#copy run start配置trunk,2950b如下:
  2950b(config)#int f0/1
  2950b(config-if)#switchport mode trunk
  2950b(config-if)#int f0/4
  2950b(config-if)#switchport mode trunk
  2950b(config-if)#int f0/5
  2950b(confgi-if)#switchport mode trunk配置trunk,2950c如下:
  2950c(config)#int f0/4
  2950c(confgi-if)#switchport mode trunk
  2950c(config-if)#int f0/5
  2950c(config-if)#switchport mode trunk
验证trunk信息,使用show interface trunk命令.如下:
  2950b#sh int trunk
  port mode encapsulation status native vlan
  fa0/1 on 802.1q trunking 1
  fa0/4 on 802.1q trunking 1
  fa0/5 on 802.1q trunking 1
  (略)
  之前我们已经对2950b和2950c做了基本配置和trunk端口的配置,接下来应该设置vtp和创建vlan,并且进行验证.2950c如下:
  2950c(config)#vtp mode server
  2950c(config)#vtp domain cisco
  2950c(config)#^z
  2950c#vlan database
  2950c(vlan)#vlan 2 name sales
  2950c(vlan)#vlan 3 name marketing
  2950c(vlan)#apply
  2950c(vlan)#^c
  2950c#sh vlan brief
  (略)接下来分配端口,把fa0/2分配给vlan2,fa0/3分配给vlan3,默认所有的端口都处在vlan1下,配置如下:
  2950c(config)#int fa0/2
  2950c(config-if)#switchport access vlan2
  2950c(config)#int fa0/3
  2950c(config-if)#switchport access vlan3
  验证信息,注意vlan1里的ports栏,如下:
  2950c#sh vlan brief
  vlan name status ports
  -------------------------------------------------------
  1 default active fa0/1 fa0/5...fa0/10
  2 sales active fa0/2
  3 marketing active fa0/3
  配置2950b,把它设置成客户模式,2950b从2950c接收vlan信息,如下:
  2950b(config)#vtp mode client
  2950b(config)#vtp domain cisco
  2950b(config)#^z
  验证,注意2950b已经从2950c知道了vlan的信息,如下:
  2950b#sh vlan brief
  vlan name status ports
  -------------------------------------------------------
  1 default active fa0/1...fa0/12
  2 sales active
  3 marketing active 但是仍然要给2950b分配端口,如下:
  2950b(config)#int fa0/2
  2950b(config-if)#switchport access vlan2
  2950b(config)#int fa0/3
  2950b(config-if)#switchport access vlan3
  验证信息,如下:
  vlan name status ports
  -------------------------------------------------------
  1 default active fa0/1 fa0/5...fa0/12
  2 sales active fa0/2
  3 marketing active fa0/3
到现在,2950c和2950b的配置就算是完成了,经过验证,我们也没发现什么问题,接下来该配置什么呢?当然是配置vlan间的通信,根据上面的拓扑图,可以知道需要在routerb上进行配置,如下:
  routerb(config)#hostname trunkrouter
  trunkrouter(config)#int f0/0
  trunkrouter(config-if)#no ip address
  trunkrouter(config-if)#no shut创建子接口,并定义封装类型,如下:
  trunkrouter(config-if)#int f0/0.1
  trunkrouter(config-subif)#encapsulation dot1q 1
  trunkrouter(config-subif)#ip address 172.16.10.1 255.255.255.0
  trunkrouter(config-if)#int f0/0.2
  trunkrouter(config-subif)#encapsulation dot1q 2
  trunkrouter(config-subif)#ip address 172.16.20.1 255.255.255.0
  trunkrouter(config-if)#int f0/0.3
  trunkrouter(config-subif)#encapsulation dot1q 3
  trunkrouter(config-subif)#ip address 172.16.30.1 255.255.255.0
  trunkrouter(config-if)#exit创建子接口,每个接口对应1个vlan.注意,如果你试图在第一个子接口分配ip地址,将收到错误信息,除非你先定义了封装类型,如下:
  trunkrouter(config-if)#int f0/0.1
  trunkrouter(config-subif)#ip address 172.16.10.1 255.255.255.0
  configuring ip routing on a lan subinterface is only allowed if that subinterface is already configured as part of an ieee 802.10, ieee 802.1q, or isl vlan.
  验证配置信息,如下:
  trunkrouter#sh run
  (略)。br

上一篇: 2层交换
下一篇: Router

相关文章:
栏目搜索
悠久范文网 www.u922.com 程序设计© 2011-2014
本站资源全部来自网络的收集 如果版权人认为本站资源影响到你的利益 请来信通知我们 我们确认后将立即删除!